Неработает transmission и вопрос по teamviewer

В процессе наполнения (доступен для записи)

Неработает transmission и вопрос по teamviewer

Сообщение bulova » 31 мар 2014, 02:47

Cкажите в чем отличие transmission на alexelec?

в openelec - transmission работает из коробки.

В сборке alexelec - пишет порт закрыт, причем пробрасываю порт на роутере - и результата никакого, всеравно пишет порт закрыт.

при этом в openelec работает все без проблем, и в роутере ничего не прописываю...

в чем отличие конфигов transmission в alexelec и openelec?


и второй вопрос - как пользоваться teamviewer?

запускать как демон - включил. где брать данные для подключения?

если запустить в программах teamviewer - то окно лицензионного соглашения ничем не закрыть и не нажать там...

инструкций по этому поводу нигде на нашел...

речь о версии alexelec V4
Аватара пользователя
bulova
 
Автор темы
Сообщения: 9
Зарегистрирован: 31 мар 2014, 02:36
Пол: Пол не указан

Re: Неработает transmission и вопрос по teamviewer

Сообщение alex » 31 мар 2014, 06:52

bulova писал(а):Cкажите в чем отличие transmission на alexelec?

Вы включили Transmission? Покажите лог системы.
и второй вопрос - как пользоваться teamviewer?

http://www.alexelec.ru/sborka-alexelecv ... #more-2083
Аватара пользователя
alex
Администратор
 
Сообщения: 6436
Изображения: 0
Зарегистрирован: 05 дек 2012, 14:10
Откуда: Киев
Национальный флаг:
Ukraine
Пол: Мужской

Re: Неработает transmission и вопрос по teamviewer

Сообщение elec » 31 мар 2014, 09:11

Аналогично не работает ("не" отдельно обычно в большинстве случаев.) transmission и у меня.
Вернее, не работал.

Решение см. здесь (ссылка, кликабельна):

Forum Alex@ELEC • Просмотр темы - AlexELECv3-ION.20131212-r0018
elec » 28 мар 2014, 15:41

alex, спасибо за прошивку.
И за головоломку с transmission - мозг надо тренировать.

Я установил приложение - локальный клиен transmission.
У него тоже были проблемы с соединением.

Затем пошел в настройки transmission.
Там, наконец, обратил внимание на настройку "Разрешить управление transmission со следующих IP адресов. Перечислите через запятую допустимые адреса"
Настройка по умолчанию была "*.*.*.*"

Добавил через запятую 127.0.0.1 - локальный клиен transmission заработал!
Затем добавил адрес компьютера в локальной сети, заработал веб-доступ к transmission по локальной сети!
Порт 9091.


Так, значит, с "*.*.*.*" какие-то проблемы?
Последний раз редактировалось elec 31 мар 2014, 14:19, всего редактировалось 1 раз.
Аватара пользователя
elec
 
Сообщения: 26
Зарегистрирован: 27 фев 2014, 11:08
Пол: Пол не указан

Re: Неработает transmission и вопрос по teamviewer

Сообщение alex » 31 мар 2014, 09:48

elec писал(а):Так, значит, с "*.*.*.*" какие-то проблемы?

На самом деле ни каких проблем с "*.*.*.*" - нет. Только что проверил.

screenshot000.png

screenshot001.png

screenshot002.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
alex
Администратор
 
Сообщения: 6436
Изображения: 0
Зарегистрирован: 05 дек 2012, 14:10
Откуда: Киев
Национальный флаг:
Ukraine
Пол: Мужской

Re: Неработает transmission и вопрос по teamviewer

Сообщение elec » 31 мар 2014, 12:18

Alex, у меня получилась связь с дополнением-клиентом transmission только после добавления через запятую адреса 127.0.0.1

Может, попробовать удалить 127.0.0.1 и оставить *.*.*.* ?
Аватара пользователя
elec
 
Сообщения: 26
Зарегистрирован: 27 фев 2014, 11:08
Пол: Пол не указан

Re: Неработает transmission и вопрос по teamviewer

Сообщение bulova » 31 мар 2014, 13:09

alex писал(а):
bulova писал(а):Cкажите в чем отличие transmission на alexelec?

Вы включили Transmission? Покажите лог системы.
и второй вопрос - как пользоваться teamviewer?

http://www.alexelec.ru/sborka-alexelecv ... #more-2083


a[14:02:59.093] Transmission 2.80 (14103) started (session.c:737)
[14:02:59.094] RPC Server Adding address to whitelist: *.*.*.* (rpc-server.c:828)
[14:02:59.094] RPC Server Serving RPC and Web requests on port 127.0.0.1:9091/transmission/ (rpc-server.c:1035)
[14:02:59.094] RPC Server Whitelist enabled (rpc-server.c:1039)
[14:02:59.094] UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
[14:02:59.094] UDP Please add the line "net.core.rmem_max = 4194304" to /etc/sysctl.conf (tr-udp.c:83)
[14:02:59.094] UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)
[14:02:59.094] UDP Please add the line "net.core.wmem_max = 1048576" to /etc/sysctl.conf (tr-udp.c:94)
[14:02:59.094] DHT Generating new id (tr-dht.c:310)
[14:02:59.094] Using settings from "/storage/.cache/transmission" (daemon.c:526)
[14:02:59.094] Saved "/storage/.cache/transmission/settings.json" (variant.c:1217)
[14:02:59.094] Watching "/storage/downloads/watch" for new .torrent files (daemon.c:564)
[14:02:59.094] Using inotify to watch directory "/storage/downloads/watch" (watch.c:74)
[14:02:59.094] Loaded 1 torrents (session.c:1976)
[14:03:01.095] Port Forwarding (UPnP) Found Internet Gateway Device "http://192.168.1.1:52869/upnp/control/WANIPConnection" (upnp.c:202)
[14:03:01.095] Port Forwarding (UPnP) Local Address is "192.168.1.51" (upnp.c:204)
[14:03:01.095] Port Forwarding (UPnP) Port forwarding through "http://192.168.1.1:52869/upnp/control/WANIPConnection", service "urn:schemas-upnp-org:service:WANIPConnection:1". (local address: 192.168.1.51:51413) (upnp.c:279)
[14:03:01.095] Port Forwarding Port Forwarding (port-forwarding.c:95)
[14:03:01.095] Bad Grandpa Could not connect to tracker (announcer.c:1000)
[14:03:01.095] Bad Grandpa Retrying announce in 317 seconds. (announcer.c:1009)
[14:03:01.095] Bad Grandpa Could not connect to tracker (announcer.c:1000)
[14:03:01.095] Bad Grandpa Retrying announce in 300 seconds. (announcer.c:1009)
[14:03:03.096] Searching for web interface file "/storage/.local/share/transmission/web/index.html" (platform.c:452)
[14:03:03.096] Searching for web interface file "/usr/share/transmission/web/index.html" (platform.c:452)
[14:03:29.111] DHT Attempting bootstrap from dht.transmissionbt.com (tr-dht.c:248)
[14:03:29.111] DHT dht.transmissionbt.com:6881: System error (tr-dht.c:126)
[14:03:51.123] DHT dht.transmissionbt.com:6881: System error (tr-dht.c:126)
[14:04:29.144] DHT dht.transmissionbt.com:6881: System error (tr-dht.c:126)
[14:05:03.163] Bad Grandpa Scrape error: Could not connect to tracker (announcer.c:1283)
[14:05:03.163] Bad Grandpa Retrying scrape in 927 seconds. (announcer.c:1292)
[14:05:03.163] DHT dht.transmissionbt.com:6881: System error (tr-dht.c:126)


я являюсь также разработчиком, и просто както обидно что openelec работает из коробки без проблем, а система кот лучше, несет такие мелкие проблемы в себе... хочу помочь это исправить...

проблема не в *.*.*.* - это лишь доступ к веб интерфейсу.... у меня как видите вебинтерфейс и доступ к нему работает без проблем изначально...

просто не работает внешнеий порт хотя проброс на роутере включал корректно (при этом для openelec ничего не включал - все работало из коробки)

почему также не сохраняются настройки через веб-интерфейс?
Аватара пользователя
bulova
 
Автор темы
Сообщения: 9
Зарегистрирован: 31 мар 2014, 02:36
Пол: Пол не указан

Re: Неработает transmission и вопрос по teamviewer

Сообщение bulova » 31 мар 2014, 13:14

автор и насчет Teamviewer - вы мне скинули ссылки на скриншот где включен демон и клиент в настройках...


до этого у меня был включен изначально только демон..

сейчас включил и клиент..

вопрос остается прежнем где брать данные авторизации teamviewer?

сделайте нормальную инструкцию....
Аватара пользователя
bulova
 
Автор темы
Сообщения: 9
Зарегистрирован: 31 мар 2014, 02:36
Пол: Пол не указан

Re: Неработает transmission и вопрос по teamviewer

Сообщение bulova » 31 мар 2014, 13:53

C transmission разобрался, проблема решена...

мучал долго settings.json

по проблема оказалась в системе - неработал резолвинг dns корректно..

вопрос по teamviewer остается открытым...

где брать данные для авторизации?
Аватара пользователя
bulova
 
Автор темы
Сообщения: 9
Зарегистрирован: 31 мар 2014, 02:36
Пол: Пол не указан

Re: Неработает transmission и вопрос по teamviewer

Сообщение elec » 31 мар 2014, 14:17

bulova писал(а):C transmission разобрался, проблема решена...
мучал долго settings.json
по проблема оказалась в системе - неработал резолвинг dns корректно..


Пожалуйста, расскажите о решении проблемы.
У вас заработало разрешение всех адресов по *.*.*.* ?
Что нужно поправить или настроить?
Аватара пользователя
elec
 
Сообщения: 26
Зарегистрирован: 27 фев 2014, 11:08
Пол: Пол не указан

Re: Неработает transmission и вопрос по teamviewer

Сообщение elec » 31 мар 2014, 14:21

bulova писал(а):[14:02:59.093] Transmission 2.80 (14103) started (session.c:737)
[14:02:59.094] RPC Server Adding address to whitelist: *.*.*.* (rpc-server.c:828)


Подскажите, пожалуйста, в каком файле лога вы нашли этот лог?
Аватара пользователя
elec
 
Сообщения: 26
Зарегистрирован: 27 фев 2014, 11:08
Пол: Пол не указан

След.


Вернуться в Подсказки, описания и FAQ по Alex@ELEC

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4


Premodded assemblage from ATS